WPJ344-A 6A08 serial issue [SOLVED]

  1. 8 months ago

    Hi All,

    I have just bought a WPJ344-A board and after connecting to the serial console through one of my numerous FTDI dongles i have an error where i see corruption of the terminal characters. I have included a screenshot of the issue. It makes it impossible to use as the corruption is on the Tx and Rx side, so commands get garbled as well as the echo reply. I can't do anything that i want to with the board as i am trying to flash OpenWRT so i can test some things.

    I hope i am doing something wrong or missed something simple. The Compex wiki and info in general is all over the place so i don't know what is relevant and what isn't.

    Do i need the special serial dongle Compex sells?

    Thanks
    84ace

  2. Winston

    17 Jun 2016 Moderator

    Dear 84ace,

    Good day! I would recommend the serial converter cable from Compex.

    You may submit your request here: http://www.compex.com.sg/contact-us/

    You can refer to this wiki page for the settings: http://wiki.compex.com.sg/wiki/WPJ344_Hardware_Manual#Serial_Console_Settings

    Best,
    Winston

  3. 6 weeks ago

    Hi Winston,

    I fixed my problem, turns out the Compex boards are a bit selective about which serial converters they work with. I have some fairly expensive ones and some cheaper ones, turns out this one https://hobbyking.com/en_us/kingduino-pl2303-usb-1.html works perfectly. I had it laying around from a micro drone and gave it a test.

    Something to note: If you power on a Compex board with a serial converter attached and you swap Tx/Rx accidently the board buzzer goes off non-stop and the board won't boot.

    I will mark this solved.

    Thanks,
    Acea

  4. Hmm, can't edit the title to add [SOLVED]

    Is that not a thing around here?

    Acea

  5. Winston

    Jan 13 Moderator

    Hi Acea,

    Glad that you have found the solution to your problem. I shall mark this as solved.

    Cheers,
    Winston

 

or Sign Up to reply!