Problem with WPQ864 and WLE1216V5

  1. 5 weeks ago
    Edited 5 weeks ago by Winston

    Hello. I was undertaking some point-to-point throughput tests with two WPQ864s and WLE1216s, and found something weird.
    The shop page for WLE1216 says that the module should be able to support bandwidth of 160MHz. However, as seen on the web LuCI interface, the HT bandwidth options for the aforementioned WiFi module only shows up to 80MHz.
    I have updated the WPQ864's firmware to the latest QSDK as given on the compex download page, but still see same results.
    Would I need to install ath10k drivers on opkg? Or is this the intended mode of operation? I do see that the max throughput as advertised on the shop page is 1.73Gbps, achievable with 4*4 80MHz streams. Would it be just a simple error?

    Thank you for any advice in advance.

  2. 4 weeks ago

    Winston

    Feb 23 Moderator

    Hi Djji,

    Kindly please let us know you refer to WLE1216V5-20 or WLE1216V5-23?

    What's the firmware version you are using on WPQ864?

    How did you connect the Mini PCIe radio cards on the WPQ864 board?

    Thanks,
    Winston

  3. 3 weeks ago

    Sorry for necroing this, I was very busy this week. Thanks for your answer

    I am referring to the WLE1216V5-23, the larger module without the heatsink.

    The firmware that I am using is the latest QSDK firmware for the WPQ864 board, obtained from the compex download page.

    The Mini PCIe cards were plugged into the 5Ghz slots, the left-top PCIe slot.

    Thanks for any help in advance.

  4. 2 weeks ago

    Winston

    Mar 10 Moderator

    Hi Djji,

    As the product is relatively new, we are still in the process of creating the functional CompexWRT firmware. Meanwhile, the only way to set it is by using the command line.

    Try entering these commands.
    uci set wireless.wifi0.hwmode=11ac
    uci set wireless.wifi0.disabled=0
    uci set wireless.wifi0.htmode=HT80_80
    uci set wireless.wifi0.channel=42
    uci set wireless.@wifi-iface[0]=wifi-iface
    uci set wireless.@wifi-iface[0].device=wifi0
    uci set wireless.@wifi-iface[0].network=lan
    uci set wireless.@wifi-iface[0].cfreq2=149
    uci set wireless.@wifi-iface[0].mode=ap
    uci set wireless.@wifi-iface[0].wds=1
    uci set wireless.@wifi-iface[0].ssid=test-wpq864-wle1216v5
    uci set wireless.@wifi-iface[0].encryption=none
    uci commit wireless

    Have a nice day,
    Winston

 

or Sign Up to reply!