WLE650V5-18A Openwrt

  1. 3 months ago

    Hi, I've recently purchased a WLE650v5-18 for use with a Turris Omnia router but can't get the firmware to load. I've tried every possible combination of the ath10k_pci-ct driver and firmware but can't get the card to work at all....

    Can any kind soul point me to the correct firmware-5.bin and board-2.bin got this currently + firmware crash...

    [ 1995.862874] firmware ath10k!cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
    [ 1995.872484] ath10k_pci 0000:02:00.0: qca9888 hw2.0 target 0x01000000 chip_id 0x00000000 sub 0000:0000
    [ 1995.872494] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
    [ 1995.875921] ath10k_pci 0000:02:00.0: firmware ver 10.4-3.3-00092 api 5 features no-p2p,mfp,peer-flow-ctrl crc32 24d91441
    [ 1997.861768] ath10k_pci 0000:02:00.0: failed to fetch board data for bus=pci,bmi-chip-id=0,bmi-board-id=17 from ath10k/QCA9888/hw2.0/board-2.bin
    [ 1997.874848] ath10k_pci 0000:02:00.0: board_file api 1 bmi_id 0:17 crc32 cabb7265
    [ 2001.301632] ath10k_pci 0000:02:00.0: firmware crashed! (uuid 56ec8cde-9be1-4732-90db-96db571e5671)
    [ 2001.310631] ath10k_pci 0000:02:00.0: qca9888 hw2.0 target 0x01000000 chip_id 0x00000000 sub 0000:0000
    [ 2001.310638] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
    [ 2001.314026] ath10k_pci 0000:02:00.0: firmware ver 10.4-3.3-00092 api 5 features no-p2p,mfp,peer-flow-ctrl crc32 24d91441
    [ 2001.314100] ath10k_pci 0000:02:00.0: board_file api 1 bmi_id 0:17 crc32 cabb7265
    [ 2001.314107] ath10k_pci 0000:02:00.0: htt-ver 0.0 wmi-op 6 htt-op 4 cal otp max-sta 32 raw 0 hwcrypto 1
    [ 2001.316142] ath10k_pci 0000:02:00.0: firmware register dump:
    [ 2001.321823] ath10k_pci 0000:02:00.0: [00]: 0x01000000 0x000015B3 0x000CA624 0x00975B31
    [ 2001.329766] ath10k_pci 0000:02:00.0: [04]: 0x000CA624 0x00060F30 0x00000011 0x3F0A6B7F
    [ 2001.337706] ath10k_pci 0000:02:00.0: [08]: 0x000C0000 0x00405E9C 0x00405EA4 0x00400000
    [ 2001.345645] ath10k_pci 0000:02:00.0: [12]: 0x00000009 0x00000000 0x000CA56C 0x000CA577
    [ 2001.353580] ath10k_pci 0000:02:00.0: [16]: 0x000CA624 0x000CA56F 0x00000000 0x00000000
    [ 2001.361518] ath10k_pci 0000:02:00.0: [20]: 0x400CA624 0x00405E1C 0x00975A00 0x00000000
    [ 2001.369459] ath10k_pci 0000:02:00.0: [24]: 0x809CF28F 0x00405E7C 0x00000001 0xC00CA624
    [ 2001.377397] ath10k_pci 0000:02:00.0: [28]: 0x809BD5B7 0x00405E9C 0x000C0000 0x00405FB0
    [ 2001.385336] ath10k_pci 0000:02:00.0: [32]: 0x809BD5E4 0x00405EDC 0x000C0000 0x00405FB0
    [ 2001.393270] ath10k_pci 0000:02:00.0: [36]: 0x809CF559 0x00405F0C 0x000C0000 0x00405FB0
    [ 2001.401217] ath10k_pci 0000:02:00.0: [40]: 0x809871E1 0x00405F2C 0x00405FAC 0x00405F6C
    [ 2001.409156] ath10k_pci 0000:02:00.0: [44]: 0x809CF6DF 0x00405F6C 0x00405FAC 0x004136EC
    [ 2001.417094] ath10k_pci 0000:02:00.0: [48]: 0x8098145F 0x00405F9C 0x00415A6C 0x00400000
    [ 2001.425032] ath10k_pci 0000:02:00.0: [52]: 0x800DA9B0 0x0040600C 0x00000004 0x004132B0
    [ 2001.432967] ath10k_pci 0000:02:00.0: [56]: 0x800C383A 0x0040603C 0x00413120 0x00400000
    [ 2002.293785] ath10k_pci 0000:02:00.0: failed to receive control response completion, polling..
    [ 2003.293724] ath10k_pci 0000:02:00.0: ctl_resp never came in (-110)
    [ 2003.299922] ath10k_pci 0000:02:00.0: failed to connect to HTC: -110
    [ 2003.365079] ath10k_pci 0000:02:00.0: could not init core (-110)
    [ 2003.371096] ath10k_pci 0000:02:00.0: could not probe fw (-110)

  2. Winston

    Feb 2 Moderator
    Edited 3 months ago by Winston

    Hi Borris,

    Thanks for reaching out.

    The QCA9888 WLE650V5-18A requires the new Qualcomm Atheros (QCA) 10.4 wireless drivers and currently only runs on WPJ563-A and WPQ864 boards loaded with QCA reference firmware containing the 10.4 wireless drivers.

    Best,
    Winston

  3. Hi Winston,

    Thanks for the reply - are those Atheros 10.4 drivers available somewhere outside of your board firmware images? I purchased the card to use in an openwrt router based on the advertised support in the linux ath10k which it doesn't appear to have with any of the existing 10.4.x drivers I've found.

    Can you provide a download link please?

    Cheers,
    Borris.

  4. Winston

    Feb 6 Moderator

    Hi Boris,

    Currently they are not available yet.

    Best,
    Winston

  5. Hi Winston,

    Fair enough, I guess the module is pretty new after all! - If you need an OpenWRT/Omina beta tester when they do become available please let me know.

    Cheers!

  6. Support for this card seems pretty bad at the moment, neither the offcial board-2.bin nor firmware-5.bin are working. (board-2.bin doesn't know the card, firmware-5.bin kernel panics with an iommu error)

    After many hours of trying I have the card working on Ubuntu16.04 (x86_64) though:
    Kernel: linux-generic-hwe-16.04-edge (4.8 from repo)
    Board: board-2.bin (From https://source.codeaurora.org/quic/qsdk/oss/firmware/ath10k-firmware/plain/ath10k/QCA9888/hw2.0/ )
    Firmware: firmware-5-ct-community.bin (QCA9888 from http://www.candelatech.com/ath10k-10.4.php )

    This is rather hacky and I'd prefer a better solution, but this seems to be working for now (I've seen some firmware crashes, but I think thats related to a second ath9k_htc card in the system)

    I don't know if this is normal, but the card seems to run rather hot, 75°C idle (only ap beacons) and up to 130°C during transfers (at 17dbm per chain). Fortunately temperature does not seem to influence stability or transfer rates (can keep the card at 90°C with a fan lying on top of it).

    Please share any further findings you may have.

  7. @arni Thanks for the information and those links. I don't think I'll be able to replicate your results unless kernel 4.4 for my platform also works but will give it a try.

    Cheers!

 

or Sign Up to reply!