OpenWRT&wpj558

  1. 4 months ago

    Hello! I have questions on the operation openwrt on the board wpj558. Probably ath9k driver not working with QCA8327 3x3 MIMO, as detected Wi-Fi devices, very low level signal. For some reason, the device has a very low sensitivity of the receiving tract. This problem exists on openwrt: CC 15.05, BB 14.07. The driver ath10k and the board of 802.11ac are working fine. What can I do?

  2. Winston

    Dec 8 Moderator

    Hi Taoga,

    Could you kindly let us know what antenna you are using please? How did you see the very low signal level of the onboard radio? Screenshots or serial console logs would be helpful to diagnose the problem. Are you using one WPJ558 board as AP mode and one WPJ558 board as Station mode?

    Best,
    Winston

  3. I use antenna: AR006-W03 [2.4/5.8GHz/ Swivel RPSMA] WELLSHOW
    For comparison I use the assembly on the basis of WPJ344 c identical antennas, cables, and modules Wi-Fi - there is no problem.
    I see low signal strength of discovered devices in monitor mode.
    I have 2 devices WPJ558.

  4. Could not transfer log in the message, so I give a link to this file:
    link text

  5. Winston

    Dec 14 Moderator

    Hi Taoga,

    Could you kindly post screenshots of the Status home page of the AP and Station showing the signal strength please?

    Did you configure the 3rd antenna to off?

    On the Compex AP configuration webpage, please navigate to:

    Network --> Wifi --> wifi0 --> Device Configuration --> Advanced Settings:

    Chainmask Selection: Sets the antenna port selection on the radio. For example, 2x2 means that 2 antennas are being used.

    http://wiki.compex.com.sg/wiki/Manual:Network/WiFi

    Best,
    Winston

  6. Hello, Winston
    I need to use OpenWRT. I used the following firmware:openwrt-15.05.1-ar71xx-generic-wpj558-16M-squashfs-sysupgrade.bin, from your website downloads.compex.com.sg
    Screenshots:
    radio0 status:
    -image-
    Signal strength:
    -image-
    Don't know where to choose 2x2 in Openwrt

  7. Screenshots:
    radio0 status:
    https://yadi.sk/i/rpxdluv433Vsa8
    Signal strength:
    https://yadi.sk/i/AmReVknn33VsZ9

  8. Was unable to install CompexWRT. Tell me: what's the problem?

    U-Boot 1.1.4 (Jul 31 2014 - 09:39:55)
    
    wpj558 - Scorpion 1.0
    
    DRAM:  128 MB
    Top of RAM usable for U-Boot at: 88000000
    Reserving 146k for U-Boot at: 87fd8000
    Reserving 192k for malloc() at: 87fa8000
    Reserving 44 Bytes for Board Info at: 87fa7fd4
    Reserving 36 Bytes for Global Data at: 87fa7fb0
    Reserving 128k for boot params() at: 87f87fb0
    Stack Pointer at: 87f87f98
    Now running in RAM - U-Boot at: 87fd8000
    Flash Manuf Id 0xc2, DeviceId0 0x20, DeviceId1 0x18
    Flash found: mx25l 16MB
    Flash: 16 MB
    Using default environment
    
    eth_set_enetaddr(num=0, addr=04:f0:21:1c:24:ac)
    eth_set_enetaddr(num=0, addr=04:f0:21:1c:24:ac)
    In:    serial
    Out:   serial
    Err:   serial
    Net:   ath_gmac_enet_initialize...
    athrs_sgmii_res_cal: cal value = 0xe
    ath_gmac_enet_initialize: reset mask:c02200 
    Scorpion  ----> S17 PHY *
    Vlan config...
    s17 phy0 register value 0x00004140
    TEST: FINAL REG VAL after TX Calibration - 0x46000000
    TEST: FINAL XMII VAL after RX Calibration - 0x56000000
    TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00014001
    athrs17_reg_init: complete
    : cfg1 0x80000000 cfg2 0x7335
    eth0: 04:f0:21:1c:24:ac
    eth0 up
    eth0
    Setting 0x18116290 to 0x2040214f
    Hit any key to stop autoboot:  0 
    ath> cpximg wpj558a-v2.4.10-b160928-16M.img
    Trying eth0
    dup 1 speed 1000
    Using eth0 device
    TFTP from server 192.168.1.10; our IP address is 192.168.1.1
    Filename 'wpj558a-v2.4.10-b160928-16M.img'.
    Load address: 0x81000000
    Loading: #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 #################################################################
    	 ############################################
    done
    Bytes transferred = 9542836 (919cb4 hex)
    Updating firmware at addr 0x81000000 ...
    Bad firmware format!

  9. Set CompexWRT. Used the firmware: wpj558-16M_mimoap-generic_v186_b151120.img
    The above-described problems have not noticed.
    Spread screenshots:
    https://yadi.sk/i/k0a2_cgK33ZYBc
    https://yadi.sk/i/TrN_ZZID33ZYC5
    https://yadi.sk/i/tgYFWMh233ZYCM

    The problem in OpenWRT?

  10. I made a mistake with openwrt in-15.05.1-ar71xx-generic-wpj558-16m-squashfs-sysupgrade.bin
    The signal level from the access point q183 normal - everything works. How can I get the source codes of Openwrt 15.05.1 with patches from Compex. Tell me where I can download? Earlier I received a link to the archive on request.

  11. Winston

    Dec 16 Moderator

    Hi Taoga,

    Glad that everything works now :-)

    There are two ways to get the source codes of Openwrt 15.05.1 with patches from Compex:

    1. Directly from OpenWRT code repository. During make menuconfig, kindly select the option for the Compex board.

    2. Here is the link: http://downloads.compex.com.sg/vfm-admin/vfm-downloader.php?q=dXBsb2Fkcy9PcGVuV1JUL0NoYW9zLUNhbG1lci8yMDE2LTAzLTE2L09wZW5XcnQtU0RLLTE1LjA1LjEtYXI3MXh4LWdlbmVyaWNfZ2NjLTQuOC1saW5hcm9fdUNsaWJjLTAuOS4zMy4yLkxpbnV4LXg4Nl82NC50YXIuYnoy&h=51bd25f784997e4c37fbc082636becaf

    Best,
    Winston

  12. Hi Winston,
    I feel like a fool. I gathered the firmware to Compex WPJ558 from four different SDK:

    1. Compex BB 14.07 SDK
    2. Compex CC 15.05 SDK
    3. from OpenWRT code repository CC 15.05
    4. from OpenWRT code trunk repository

    All-level signal from the phy0(radio0, ath9k) was 40 dB below the actual level. I don't use the web interface luci. All radios in the system are included. It seems to me that we need to include the input amplifiers or to choose the right antenna( 2x2, 3x3 ). I will try the SDK that you sent me. I've already downloaded it, but I thought it was not as compex SDK as I did previously.

  13. Hello Winston,
    I rescind my question, on your WPJ558 everything works. I used your SDK: chaos_calmer_ge13f8ac3_b160310.tar.xz. tcpdump 4.5.1 helped me a lot. The bug was related to improper calculation of the displacement of the header ieee80211_radiotap_header. Thank you for your assistance.

  14. Winston

    Dec 22 Moderator

    Hi Taoga,

    Happy that you managed to solve the problem. Glad to be of help.

    Thanks,
    Winston

  15. Newer ›
 

or Sign Up to reply!